Most come for the information and opportunity. Most stay for the friendships that are formed. Welcome!


 
GalleryHomePortalFAQRegisterLog in

Share | 
 

 Another water pump seal gone bad

Go down 
AuthorMessage
chipper
SSXSRider Member
avatar

Number of posts : 1035
Registration date : 2010-12-30
Age : 48
Location : Danville

PostSubject: Another water pump seal gone bad   Sun Nov 13, 2011 4:37 pm

I just replaced a water pump seal the first of june and the seal is leaking again. What the hell causes these to go bad? I was told it was from playing in mud and such which I very rarely do anymore. Any time I ride I put grease in the weap hole and then spray a wd-40 to wash it afterwards. Anyone have ideas for my new seal?
Back to top Go down
nocerisdave
SSXSRider Member
avatar

Number of posts : 5674
Registration date : 2008-01-22
Age : 53
Location : Laceys Spring AL

PostSubject: Re: Another water pump seal gone bad   Sun Nov 13, 2011 6:16 pm

Sounds like you dont have a flat surface on either the pump or the engine. I would flatten them both just to make sure thats not the problem. Here is how to do it.

Use the flattest surface you have. Big enough you can sit the pump on it with some extra surface area on the flat surface. Use double back tape to hold the sand paper on the flat surface. I would start with around 180 grit. Use some finger nail polish and paint the flat surfaces. Spray paint will work too. Diechem is the best thing to use but not many have it in their garage. http://www.ebay.com/itm/KART-cart-MOTORCYCLE-RACING-MACHINIST-STEEL-LAYOUT-DYE-/260661516896?pt=Motors_Automotive_Tools&vxp=mtr&hash=item3cb0a31a60#ht_1412wt_1139

Move the pump over the sand paper a couple of times. Any paint left on the pump will be a low spot and high spots where there is no paint. Repeat this on the mating flat surface on the engine. If the surface (s) are not flat continue sanding until all paint is gone. Move to 400 grit and repeat.

It may not be a fix, if not, at least that is eliminated as the problem.










Back to top Go down
chipper
SSXSRider Member
avatar

Number of posts : 1035
Registration date : 2010-12-30
Age : 48
Location : Danville

PostSubject: Re: Another water pump seal gone bad   Sun Nov 13, 2011 6:49 pm

Thanks Dave, I'llgive that a try. The pump would be the plastic piece propeller type that I pull I guess. I'm not planning on pulling the engine, what do you check in there? I'm guessing being aluminum I won't do much there though.
Back to top Go down
nocerisdave
SSXSRider Member
avatar

Number of posts : 5674
Registration date : 2008-01-22
Age : 53
Location : Laceys Spring AL

PostSubject: Re: Another water pump seal gone bad   Sun Nov 13, 2011 11:34 pm

Chipper I didnt know the water pump is plastic. I thought it was aluminum. I dont believe what I posted will help. Sorry for the bad info. If you haven't read this thread it may help.

http://www.rzrforums.net/projects-how/43085-step-step-how-replace-water-oil-pump-seal.html
Back to top Go down
chipper
SSXSRider Member
avatar

Number of posts : 1035
Registration date : 2010-12-30
Age : 48
Location : Danville

PostSubject: Re: Another water pump seal gone bad   Mon Nov 14, 2011 8:27 am

Ya, I read that the first time. Thanks though. I'm pretty sure It's plastic if memory serves me right. I'll try again and see what happens.
Back to top Go down
Sponsored content




PostSubject: Re: Another water pump seal gone bad   

Back to top Go down
 
Another water pump seal gone bad
Back to top 
Page 1 of 1
 Similar topics
-
» Dirty Clutches & Water Pump Seal
» Water pump seal
» Highbanker + water pump legal?
» Bait Pump Seal Repair
» 12v water pump.

Permissions in this forum:You cannot reply to topics in this forum
SouthernSxSRiders :: The Machines :: Polaris-
Jump to: